解决WordPress 不支持magnet、ed2k 新协议支持

原标题:WordPress 超链接增加magnet、ed2k 新协议支持

需要在Wordpress的超链接中增加对magnet、ed2k等新协议的支持,效果类似:

肖申克的救赎

为防范SQL注入、XSS等攻击,Wordpress会在保存博客内容时候,对内容自动过滤,导致会对超链接中不支持的协议protocol头(例如:magnet:?xt=urn:btih: ),自动删除掉。

google结果,大部分都是简单粗暴的方案:

修改 wp-includes/post.php,将相关内容注释掉。

//$postarr = sanitize_post($postarr, 'db');

但这样放弃了Wordpress原本的防范措施,不建议采用。

推荐的解决办法(推荐方案2):

方案1:修改 wp-includes/functions.php,增加新协议支持

修改 wp-includes/functions.php 的function wp_allowed_protocols()

if ( empty( $protocols ) ) {
 $protocols = array( 'http', 'https', 'ftp', 'ftps', 'mailto', 'news', 'irc', 'gopher', 'nntp', 'feed', 
'telnet', 'mms', 'rtsp', 'sms', 'svn', 'tel', 'fax', 'xmpp', 'webcal', 'urn' );
        }

直接增加需要添加的新协议,例如:

 if ( empty( $protocols ) ) {
$protocols = array( 'http', 'https', 'ftp', 'ftps', 'mailto', 'news', 'irc', 'gopher', 'nntp', 'feed', 
'telnet', 'mms', 'rtsp', 'sms', 'svn', 'tel', 'fax', 'xmpp', 'webcal', 'urn' ,'magnet','ed2k');
        }

此种方案存在一个问题:由于是全局性修改,Wordpress每一次版本升级,都会覆盖修改functions.php 文件,必须手工再次修改此文件。

方案2:在现有主题theme,增加新协议支持

修改 wp-content/themes/对应的theme名称/functions.php ,增加如下内容:

function ss_allow_magneted2k_protocol( $protocols ){
    $protocols[] = 'magnet';
    $protocols[] = 'ed2k';
    return $protocols;
}
add_filter( 'kses_allowed_protocols' , 'ss_allow_magneted2k_protocol' );

已发布

分类

作者:

标签

评论

《“解决WordPress 不支持magnet、ed2k 新协议支持”》 有 1 条评论

  1. 楚狂人 的头像

    感谢分享解决方法

发表回复

您的电子邮箱地址不会被公开。 必填项已用*标注